nixos/machines/tempore/hardware.nix
Ivan Bushchik 48ed1068be
Add "tempore" machine - VPS for Wireguard
Signed-off-by: Ivan Bushchik <ivabus@ivabus.dev>
2024-05-07 18:38:30 +03:00

11 lines
340 B
Nix

{ modulesPath, ... }: {
imports = [ (modulesPath + "/profiles/qemu-guest.nix") ];
boot.loader.grub.device = "/dev/vda";
boot.initrd.availableKernelModules =
[ "ata_piix" "uhci_hcd" "xen_blkfront" "vmw_pvscsi" ];
boot.initrd.kernelModules = [ "nvme" ];
fileSystems."/" = {
device = "/dev/vda1";
fsType = "ext4";
};
}