nixos/roles/latex.nix
Ivan Bushchik 9de8497113
Call nixfmt for the first time
Signed-off-by: Ivan Bushchik <ivabus@ivabus.dev>
2023-09-06 16:10:11 +03:00

15 lines
402 B
Nix

{ config, pkgs, lib, ... }:
let cfg = config.my.roles.latex;
in {
options.my.roles.latex.enable = lib.mkEnableOption "Enable latex stuff";
config = lib.mkIf (cfg.enable) {
environment.systemPackages = with pkgs;
[
# Maybe I don't need to use -full variant of texlive
# TODO: I should find distribution I actually need
texlive.combined.scheme-full
];
};
}